microblaze architecture · Supported
Maintainers
- M Michal Simek <monstr@monstr.eu>
Paths
- F
arch/microblaze/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-s390 (capped at 30), ordered by date desc.
-
STALE79d
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE78d
REVIEWED: 12 (12M) [PATCH v2 1/6] mm: change to return bool for ptep_test_and_clear_young()
2026-03-21 · Baolin Wang <baolin.wang@linux.alibaba.com> -
STALE101d
[PATCH 1/6] mm: change to return bool for ptep_test_and_clear_young()
2026-03-19 · Baolin Wang <baolin.wang@linux.alibaba.com> -
STALE129d
[PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE129d
[PATCH v3 10/29] microblaze: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE147d
[PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE147d
[PATCH v2 09/28] microblaze: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE196d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE196d
[PATCH 09/28] microblaze: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE280d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE280d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE280d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE302d
LANDED [PATCH v2 3/4] arch: copy_thread: pass clone_flags as u64
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE365d
[PATCH 1/1] uapi/termios: remove struct ktermios from uapi headers
2025-07-16 · "H. Peter Anvin" <hpa@zytor.com> -
STALE402d
[PATCH 2/2] arch: use always-$(KBUILD_BUILTIN) for vmlinux.lds
2025-06-02 · Masahiro Yamada <masahiroy@kernel.org> -
STALE421d
REVIEWED: 5 (5M) [PATCH v5 7/7] fs: introduce file_getattr and file_setattr syscalls
2025-05-13 · Andrey Albershteyn <hidden> -
STALE448d
[PATCH v2 03/12] mm: Call ctor/dtor for kernel PTEs
2025-04-08 · Kevin Brodsky <hidden> -
STALE445d
REVIEWED: 5 (5M) [PATCH v4 3/3] fs: introduce getfsxattrat and setfsxattrat syscalls
2025-03-21 · Andrey Albershteyn <hidden> -
STALE480d
[PATCH 02/11] mm: Call ctor/dtor for kernel PTEs
2025-03-17 · Kevin Brodsky <hidden> -
STALE424d
[PATCH v2 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE424d
[PATCH v2 11/13] arch, mm: streamline HIGHMEM freeing
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE424d
[PATCH v2 10/13] arch, mm: set high_memory in free_area_init()
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE424d
[PATCH v2 09/13] arch, mm: set max_mapnr when allocating memory map for FLATMEM
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE489d
[PATCH 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE489d
[PATCH 11/13] arch, mm: streamline HIGHMEM freeing
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE489d
[PATCH 10/13] arch, mm: set high_memory in free_area_init()
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE489d
[PATCH 09/13] arch, mm: set max_mapnr when allocating memory map for FLATMEM
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE463d
REVIEWED: 2 (0M) [PATCH v7 3/6] syscall.h: introduce syscall_set_nr()
2025-03-03 · Dmitry V. Levin <hidden> -
STALE410d
LANDED [PATCH v2 1/1] mm: pgtable: fix pte_swp_exclusive
2025-02-18 · Magnus Lindholm <linmag7@gmail.com> -
STALE513d
[PATCH 2/7] mm: Introduce a common definition of mk_pte()
2025-02-17 · "Matthew Wilcox (Oracle)" <willy@infradead.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE196d
[PATCH 09/28] microblaze: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE196d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE147d
[PATCH v2 09/28] microblaze: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE129d
[PATCH v3 10/29] microblaze: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org>